Forum: 0.7 Beta White Screen of Death

 

« Back To Thread List

marcjohnson
3609 days ago
Thanks for getting 0.7 out!
As a dutiful tester, I immediately installed 0.7 over a functioning 0.6.
I get the php white screen of death. Things I have tried to no avail:

- I enabled error_reporting(1)... but still see no error messages.
- I re-built my config using the new 0.7 config.php file, but no help.
- set short_open_tag both ways in php.ini
- tested in both IE and Firefox

I did a reverability test, and reinstalled the previous version (0.6) and it works.
Any tips for debugging?

Thanks!
Marc
joncombe
3609 days ago
Not the best start, though I'm pleased to report others are up and running OK.

Try commenting out lines 31 & 32 of index.php, i.e.:

//error_reporting(0);
//set_error_handler("ErrorHandler");

...and let me know what happens.
marcjohnson
3609 days ago
Commented out lines. No message, no improvement.
joncombe
3609 days ago
Hrmmm... can you edit the languages/translations.php to just be an empty file? Or just if it complains at that?
marcjohnson
3609 days ago
I enabled logging in php.ini.

With or without an empty languages/translation.php - I get the following errors logged:

[25-Jan-2009 12:15:25] PHP Notice: Undefined index: year in D:\Inetpub\Websites\TrainStats\jawstats\index.php on line 59

[25-Jan-2009 12:15:25] PHP Notice: Undefined index: month in D:\Inetpub\Websites\TrainStats\jawstats\index.php on line 59

[25-Jan-2009 12:15:25] PHP Notice: Undefined variable: aTemp in D:\Inetpub\Websites\TrainStats\jawstats\clsAWStats.php on line 331

[25-Jan-2009 12:15:25] PHP Fatal error: Call to undefined function Error() in D:\Inetpub\Websites\TrainStats\jawstats\clsAWStats.php on line 332
marcjohnson
3609 days ago
OK, now I turned off warnings, restarted the web sersver. Now am just getting this error:

[25-Jan-2009 12:41:07] PHP Fatal error: Call to undefined function Lang() in D:\Inetpub\Websites\TrainStats\jawstats\index.php on line 112
marcjohnson
3608 days ago
Found the problem!

There was a naked <? instead of <?php in front of the final function block in index.php. I changed it to "<?php", and it now works!
joncombe
3608 days ago
Great stuff, Marc, thanks for finding that. I'll fix it in the releases ASAP.
joncombe
3608 days ago
ZIP, TAR.GZ and public SVN now all have the fixed code.
Driftdigital
2140 days ago
You have the same problem on line 257.

Should be:

Driftdigital
2140 days ago
Well, the reply did nt work but you get the picture...

line 257 of index.php should have the full php script tag or change php tag settings in php.ini

« Back To Thread List

Participate in this discussion

 

You must be logged in to post in this thread.

 

Version 0.7 beta available now

Released 25th Janury 2009

Try the online demo or download now.

 
Latest JAWStats News:

Version 0.7 Beta Released

Sprechen Sie Deutsch? Multi-lingual JAWStats v0.7 is finally here.

posted 25th Jan '09. read more »
 

Help JAWStats

Please donate a dollar (or more!) towards the hosting costs for this site. This money doesn't go anywhere near my pocket, it is purely used against my hosting bill.

 

Get $50 off your webhosting

You could do far worse than choose Dreamhost. I've used them for 6 years and they're great. Simply enter the promo code: JAWSTATS on signup!