Forum: Spider's page error

 

« Back To Thread List

tehprince
3618 days ago
When trying to view the spider stats nothing shows up, so I did a bit of digging with FireBug.

Here are the params being passed:
config - mysiteconfig
month - 1
section - ROBOT
year - 2009

Here is the response I'm getting:
PHP Notice: Undefined offset: 1 in D:\IISrv\mywebsite\clsAWStats.php on line 195


Here's what the robots section of my data file looks like:

# Robot ID - Hits - Bandwidth - Last visit - Hits on robots.txt
# The 10 first Hits must be first (order not required for others)
BEGIN_ROBOT 36
slurp 2552 300021078 20090115170026 137
googlebot 2164 168106876 20090115170314 22
msnbot 1058 16669625 20090115165519 314
java 449 8236774 20090115161223 0
spider 221 19273975 20090114033138 2
bot[+:,\.\;\/\\-] 187 4909485 20090111053026 1
mnogosearch 98 1874953 20090115062013 15
msnbot\-media 97 2013 20090114182227 50
speedy 79 3429665 20090115000932 26
gigabot 73 7480009 20090115153257 16
ia_archiver\-web\.archive\.org 60 119587 20090105212503 60
no_user_agent 55 551838 20090115043224 8
microsoft[_+ ]url[_+ ]control 3 21255 20090114133526 0
END_ROBOT

Any idea why this isn't working properly?
Erick
3487 days ago
I ran into the same problem. My spiders page was working perfectly until I added a new custom robot defined as "site[_+ ]24[_+ ]x[_+ ]7".

I believe the issue is the "[_+ ]". The problem is the space. JAWStats is looking for spaces to separate the data fields.

Honestly, this seems to be an issue with AWStats. Even AWStats is screwing up the statistic labeling my new bot as "Others" with Hits of "-5993+6075".

Try going to your AWStats directory wwwroot/cgi-bin/lib and edit the robots.pm file. Replace all "[_+ ]" with "[_+]". You'll have to reprocess all of your data files.
Erick
3487 days ago
Confirmed it is a bug with AWStats. It has been reported 3 times:

http://sourceforge.net/tracker/?func=detail&aid=2054972&group_id=13764&atid=113764
http://sourceforge.net/tracker/?func=detail&aid=2614549&group_id=13764&atid=113764
http://sourceforge.net/tracker/?func=detail&aid=2720309&group_id=13764&atid=113764

The previous recommendation works as long as your web log does record the User Agent with spaces. I just tried it.

« Back To Thread List

Participate in this discussion

 

You must be logged in to post in this thread.

 

Version 0.7 beta available now

Released 25th Janury 2009

Try the online demo or download now.

 
Latest JAWStats News:

Version 0.7 Beta Released

Sprechen Sie Deutsch? Multi-lingual JAWStats v0.7 is finally here.

posted 25th Jan '09. read more »
 

Help JAWStats

Please donate a dollar (or more!) towards the hosting costs for this site. This money doesn't go anywhere near my pocket, it is purely used against my hosting bill.

 

Get $50 off your webhosting

You could do far worse than choose Dreamhost. I've used them for 6 years and they're great. Simply enter the promo code: JAWSTATS on signup!